このページではバーコードに関する情報を掲載しています。
Interludeでは次のバーコードに対応しています。それぞれのバーコードには規則があり、それぞれの規則を満たしていない場合は表示/印刷することができません。以下にそれぞれのバーコードに関する規則とInterludeでの仕様を挙げます。
バーコード種類 | 規則 | 仕様
JAN/EAN/UPC(Aバージョン) 必ず12桁でなければならない
使用できる文字は0～9の数字のみ 		チェックデジットはInterludeが自動的に付与します

UPCを使用する場合は先頭に0を加えることで正しいバーコードが印刷できます
(01234567890ならば001234567890のようにする)
CODE39 桁数の制限は無い
使用できる文字は0～9 の数字、 A～Z の文字、-. $/+%*の記号 の 44種類 		チェックデジットは付与しません
NW-7
(CODA-BAR) 		桁数の制限は無い
使用できる文字は0～9 の数字、 A～D の文字、-$:/.+の記号 の 20種類
先頭と最後の文字は必ず A B C D のどれかでなければならない 		チェックデジットは付与しません
ITF
(Interleaved 2 of 5) 		必ず奇数桁でなければならない
使用できる文字は0～9の数字のみ 		チェックデジットはInterludeが自動的に付与します
短縮JAN 必ず7桁でなければならない
使用できる文字は0～9の数字のみ 		チェックデジットはInterludeが自動的に付与します
UPC(Eバージョン) 必ず7桁でなければならない
使用できる文字は0～9の数字のみ 		チェックデジットはInterludeが自動的に付与します
郵便カスタマバーコード 住所から郵便カスタマバーコードへの変換方法は最寄りの郵便局などにお尋ね下さい Interludeへは変換後のコードを渡します
Interludeでは住所名からコードへの変換作業はサポートしていません
CODE128 | CODE A,CODE B,CODE Cに対応してます | チェックデジットはInterludeが自動的に付与します
EAN-128 | CODE128をベースに規格化されたコードです | 'STARTC'、'FUNC1'、チェックデジットはInterludeが自動的に付与します
QRコード ２次元バーコード ・誤り訂正レベルは、約7,15,25,30%が選択できます
・シンボルの型番、マスキングパターンは自動的に処理されます
この文書の著作権は株式会社マイクロリンクが保有しています。
Copyright (C) 1997-2005 MICROLINK Corp.


このページでは帳票設定ダイアログでの設定方法を掲載しています。
Interludeでは帳票毎に様々な設定を行うことが可能です。
設定メニューの帳票設定でこれらの設定を行うことができます。
追加
帳票設定を追加します。通常は帳票ファイルを開いて設定を行いますが、追加をすれば帳票ファイルを開く必要はなくなり、設定だけを行うことができます。
削除
選択している帳票設定を削除します。削除した設定はダイアログのキャンセルをしても元には戻りませんので慎重に操作してください。
デフォルトの設定は削除することができません。
変更
選択している帳票設定を違う名前のものに変更します。
デフォルトの設定名は変更することができません。
複製
選択している帳票設定を複製します。同じ設定内容が複数ある場合に便利です。
インポート
エクスポートした設定ファイルまたはMAGIC Previewerの設定ファイルを組み込みます。
設定する帳票ファイルの設定がすでに存在している場合はインポートされるデータによって上書きされます。
エクスポート
設定ファイルの情報をファイルに書き出します。
書き出した設定ファイルはインポートすることによって他のコンピュータで動作するInterludeで使用できるほか、MAGIC Previewerでも使用することができます。
単一の設定内容をエクスポートした場合のファイル名はファイル名+.iniで固定です。
すべての設定内容をエクスポートした場合のファイル名はInterlude.iniで固定です。

基本設定

文書名
帳票に文書名を付けます。ここで付けた文書名はファイル選択ダイアログなどの表示で使用されます。
ヘッダ
帳票のヘッダファイルを指定します。
ヘッダファイルを指定すると帳票の各ページの先頭に拡張制御命令のファイル挿入を行うことと同等となります。
連続帳票の際にはページの先頭部分が特定できないことがあります。そのような場合にはこの機能を使用するのが便利です。
フッタ
帳票のフッタファイルを指定します。
フッタファイルはヘッダファイルと同様ですが、こちらはページの末尾にファイル挿入を行うことと同等になります。

帳票設定

行数指定
1ページの行数を0から99の間で設定します。設定した行数にならなくても改ページコード(アスキーコード0x0C)で改ページが行われます。
0を指定すると連続帳票として扱われます。
桁数設定
1行の桁数を2から500の間で設定します。1行の長さに合わせて設定してください。
タブ指定
タブをいくつのスペースに展開するかを、0から9の間で設定します。
改行幅
改行をした時の間隔を1/120インチ単位で0から99の間で設定します。
レフトマージン
印刷開始位置を文字単位で0から200の間で設定します。
この指定は拡張制御命令による描画命令にも適用されます。
垂直タブ
印刷開始位置を行単位で0から100の間で設定します。
この指定は拡張制御命令による描画命令にも適用されます。

フォント

フォント名
使用するフォントをダイアログから選びます。基本的にどのフォントでも使用できますが、等幅フォントでないと桁合わせなど表示/印刷が綺麗に行われないなど問題が発生する場合がありますのでご注意ください。
もちろん英語フォントを使用して漢字を表示/印刷することは、ほとんどの場合不可能です。
文字種類
使用する文字の種類を選択します。
文字間隔
文字と文字との間隔を0から4の間で設定します。ただし文字種類がパイカの場合はこの項目を設定することはできません。
フォントの位置合わせ
フォントのベースラインを上線にするか下線にするかを設定します。
実際にこの設定が反映されるのは縦倍角など1行に複数の高さの文字が混在する場合です。

拡張制御

拡張ESCコード
制御機能を使用するための制御文字を設定します。
文字を指定した場合はその文字を、2桁の16進数が指定された場合はそのアスキーコードに対応する文字を制御文字として使用します。
拡張FSコード
この設定はMAGIC Previewerとの互換のために残されています。
拡張制御コード
拡張制御機能を使用するための制御文字を設定します。
文字を指定した場合はその文字を、2桁の16進数が指定された場合はそのアスキーコードに対応する文字を制御文字として使用します。
罫線補完の実行
dbMAGICを使用して枠線をテキスト化する場合に罫線が断片的になるため、それをInterludeで補完するかどうかを設定します。
dbMAGICを使用しない場合はこの設定は解除するようにしてください。

印刷

プリントマネージャの使用
Windowsの印刷処理を使用して印刷を行うかどうかを設定します。
印刷処理をしない場合には指定したアプリケーションを起動させることができます。
プリンタの設定
プリンタの設定を行います。
プリンタの設定ダイアログで設定したすべての内容はレジストリに保存され、印刷を行う場合には保存した設定を使用することができます。この設定も帳票毎に行うことができます。
印刷時の実行プログラム
Windowsの印刷処理を使用しない場合に、代わりに実行するプログラムのコマンドラインを設定します。
印刷前の実行プログラム
印刷処理を行う前(印刷ダイアログの表示前)に実行するプログラムのコマンドラインを設定します。
印刷後の実行プログラム
印刷処理が終了した後に実行するプログラムのコマンドラインを設定します。

座標定義

定義座標の登録・編集
リストボックスから登録または編集する定義番号を選択して、値を入力します。単位を切り替えると数値も同様に変換されます。
定義座標の削除
選択した定義内容を消去します。内容は消去されますが、以降の定義内容が詰められることはありません。
この文書の著作権は株式会社マイクロリンクが保有しています。
Copyright (C) 1997 MICROLINK Corp.


このページでは制御機能の書式や機能などのリファレンスを掲載しています。

制御機能は「制御文字＋キーワード」の形で、通常のテキスト中に埋め込んで使用します。制御文字として使用するキャラクタのデフォルトはESCコード(0x1B)ですが、帳票設定で他の文字を使用することもできます。ただし、帳票設定で他のキャラクタを使用した場合も、ESCコード(0x1B)は制御文字として使用することができます。

ボールド体(太字)
アンダーライン(下線)
イタリック体(斜体)
網掛け
フォント変更
拡大文字
改行幅
回転
色設定

ボールド体(太字)

設定( [image]) デフォルト !
文字をボールド体(太字)にします。
解除( [image]) デフォルト "
文字のボールド体(太字)状態を解除します。
書式例 表示/印刷イメージ
[ESC]!ボールド[ESC]"解除
→戻る

アンダーライン(下線)

設定( [image]) デフォルト X
文字にアンダーライン(下線)を付けます。
解除( [image]) デフォルト Y
文字のアンダーライン(下線)状態を解除します。
書式例 表示/印刷イメージ
[ESC]Xアンダーライン[ESC]Y解除
→戻る

イタリック体(斜体)

設定( [image]) デフォルト I
文字をイタリック体(斜体)にします。
解除( [image]) デフォルト S
文字のイタリック体(斜体)状態を解除します。
書式例 表示/印刷イメージ
[ESC]Iイタリック体[ESC]S解除
→戻る

網掛け

設定( [image]) デフォルト M%1d (%1は1～5の数値)
文字に指定した濃度で網掛けを施します。
濃度1( [image]) デフォルト M1
文字に濃度1の網掛けを施します。
濃度2( [image]) デフォルト M2
文字に濃度2の網掛けを施します。
濃度3( [image]) デフォルト M3
文字に濃度3の網掛けを施します。
濃度4( [image]) デフォルト M4
文字に濃度4の網掛けを施します。
濃度5( [image]) デフォルト M5
文字に濃度5の網掛けを施します。
解除( [image]) デフォルト N
文字に指定された網掛けを解除します。
書式 | パラメータ
[ESC]M%1d | %1 | 濃度(1～5)
書式例 表示/印刷イメージ
[ESC]M1網掛け1[ESC]N解除
[ESC]M2網掛け2[ESC]N解除
[ESC]M3網掛け3[ESC]N解除
[ESC]M4網掛け4[ESC]N解除
[ESC]M5網掛け5[ESC]N解除
→戻る

フォント変更

パイカ( [image]) デフォルト カDP__ ※ 実際にはカは1バイトカナ _ はスペースです
フォントをパイカ書体に変更します。
半角( [image]) デフォルト カDH%1d_ ※ 実際にはカは1バイトカナ _ はスペース %1は文字間隔(0～4)
フォントを半角書体に変更します。%1に指定した数字で文字間隔を調整することができます。
文字間隔0( [image]) デフォルト カDH0_ ※ 実際にはカは1バイトカナ _ はスペースです
フォントを半角書体に変更し、文字間隔を0に設定します。
文字間隔1( [image])デフォルト カDH1_ ※ 実際にはカは1バイトカナ _ はスペースです
フォントを半角書体に変更し、文字間隔を1に設定します。
文字間隔2( [image])デフォルト カDH2_ ※ 実際にはカは1バイトカナ _ はスペースです
フォントを半角書体に変更し、文字間隔を2に設定します。
文字間隔3( [image])デフォルト カDH3_ ※ 実際にはカは1バイトカナ _ はスペースです
フォントを半角書体に変更し、文字間隔を3に設定します。
文字間隔4( [image])デフォルト カDH4_ ※ 実際にはカは1バイトカナ _ はスペースです
フォントを半角書体に変更し、文字間隔を4に設定します。
縮小( [image]) デフォルト カDI%1d_ ※ 実際にはカは1バイトカナ _ はスペース %1は文字間隔(0～4)
フォントを縮小書体に変更します。%1に指定した数字で文字間隔を調整することができます。
文字間隔0( [image]) デフォルト カDH0_ ※ 実際にはカは1バイトカナ _ はスペースです
フォントを縮小書体に変更し、文字間隔を0に設定します。
文字間隔1( [image])デフォルト カDI1_ ※ 実際にはカは1バイトカナ _ はスペースです
フォントを縮小書体に変更し、文字間隔を1に設定します。
文字間隔2( [image])デフォルト カDI2_ ※ 実際にはカは1バイトカナ _ はスペースです
フォントを縮小書体に変更し、文字間隔を2に設定します。
文字間隔3( [image])デフォルト カDI3_ ※ 実際にはカは1バイトカナ _ はスペースです
フォントを縮小書体に変更し、文字間隔を3に設定します。
文字間隔4( [image])デフォルト カDI4_ ※ 実際にはカは1バイトカナ _ はスペースです
フォントを縮小書体に変更し、文字間隔を4に設定します。
書式 | パラメータ | 備考
[ESC]カDH%1d_ | %1 | 文字間隔(0～4) | 実際にはカは1バイトカナ _ はスペースを指定
[ESC]カDI%1d_ | %1 | 文字間隔(0～4)
書式例 | 表示/印刷イメージ | 備考
[ESC]カDP__パイカ | 実際にはカは1バイトカナ _ はスペースを指定。
[ESC]カDH0_半角0[ESC]カDP__パイカ
[ESC]カDH1_半角1[ESC]カDP__パイカ
[ESC]カDH2_半角2[ESC]カDP__パイカ
[ESC]カDH3_半角3[ESC]カDP__パイカ
[ESC]カDH4_半角4[ESC]カDP__パイカ
[ESC]カDI0_縮小0[ESC]カDP__パイカ
[ESC]カDI1_縮小1[ESC]カDP__パイカ
[ESC]カDI2_縮小2[ESC]カDP__パイカ
[ESC]カDI3_縮小3[ESC]カDP__パイカ
[ESC]カDI4_縮小4[ESC]カDP__パイカ
→戻る

拡大文字

拡大文字( [image]) デフォルト e%1d%2d ※ %1は縦倍率 %2は横倍率
文字を縦横任意の倍率で拡大します。
縦倍角( [image]) デフォルト e21
文字を縦倍角にします。
横倍角( [image]) デフォルト e12
文字を横倍角にします。
4倍角( [image]) デフォルト e22
文字を4倍角にします。
通常文字( [image]) デフォルト e11
文字を通常の大きさに戻します。
書式 | パラメータ
[ESC]e%1d%2d | %1 | 縦方向の倍率
%2 | 横方向の倍率
書式例 表示/印刷イメージ
[ESC]e21縦倍角[ESC]e11通常
[ESC]e12横倍角[ESC]e11通常
[ESC]e224倍角[ESC]e11通常
→戻る

改行幅

改行幅( [image]) デフォルト T%1D ※ %1は改行幅(1/120インチ単位)
改行幅を1/120インチ単位で変更します。
書式 | パラメータ
[ESC]T%1D | %1 | 改行幅(1/120インチ単位)
書式例 表示/印刷イメージ
[ESC]T10改行幅10
[ESC]T20改行幅20
次の行
→戻る

回転

回転( [image]) デフォルト R%1d ※ %1は回転種別(0～3)
文字を指定した角度に回転します。
90度回転( [image]) デフォルト R1
文字を時計方向に90度回転します。
180度回転( [image]) デフォルト R2
文字を時計方向に180度回転します。
270度回転( [image]) デフォルト R3
文字を時計方向に270度回転します。
通常文字( [image]) デフォルト R0
文字を通常文字に戻します。
書式 | パラメータ
[ESC]R%1d | %1 | 回転種別 | 回転角度
0 | 0度
1 | 90度
2 | 180度
3 | 270度
書式例 表示/印刷イメージ
[ESC]R190度[ESC]R0戻す
[ESC]R2180度[ESC]R0戻す
[ESC]R3270度[ESC]R0戻す

→戻る

色設定

色設定 ( [image]) デフォルト C%1X%2X%3X ※ %1は赤、%2は緑、%3は青の各要素
文字の色を変更します。
書式 | パラメータ
[ESC]C%1X%2X%3X | %1 | 赤要素(0～255)
%2 | 緑要素(0～255)
%3 | 青要素(0～255)
書式例 表示/印刷イメージ
[ESC]CFF0000赤[ESC]C000000戻す
[ESC]C00FF00緑[ESC]C000000戻す
[ESC]C0000FF青[ESC]C000000戻す
→戻る


このページでは拡張制御機能の書式や機能などのリファレンスを掲載しています。

拡張制御機能は「拡張制御文字＋キーワード行」の形で、1行1命令として使用します。制御文字として使用するキャラクタのデフォルトは$(0x24)ですが、帳票設定で他の文字を使用することもできます。また、行頭に拡張制御文字を2つ重ねることによってその行をコメント化することもできます。
図形(直線)
図形(矩形)
図形(楕円)
図形(角の丸い矩形)
図形(円弧)
図形(扇形)
バーコード
画像
テキスト
色指定
移動
ファイル挿入
壁紙指定
エイリアス

図形

直線

直線( [image]) デフォルト LINE=%1,%2,%3,%4,%5
始点と終点の間に指定した線幅の直線を描画色を使用して印刷します。
書式 | パラメータ
$LINE=%1,%2,%3,%4,%5 | %1 | 始点の横座標(スケール値:省略時は0)
%2 | 始点の縦座標(スケール値:省略時は0)
%3 | 終点の横座標(スケール値:省略時は0)
%4 | 終点の縦座標(スケール値:省略時は0)
%5 | 線幅(省略時は1)
書式例 表示/印刷イメージ
$LINE=10,10,50,10
$LINE=10,10,50,10,2

→戻る

矩形

矩形( [image]) デフォルト BOX=%1,%2,%3,%4,%5,%6
指定した矩形を描きます。
線幅が0の時には矩形の境界線は印刷されません。
塗り潰し濃度は0(塗り潰さない)から8(もっとも濃く)の間で指定します。
矩形は描画色で境界線を、背景色で塗り潰し部分を印刷します。
書式 | パラメータ
$BOX=%1,%2,%3,%4,%5,%6 | %1 | 矩形の左上隅を表す横座標(スケール値:省略時は0)
%2 | 矩形の左上隅を表す縦座標(スケール値:省略時は0)
%3 | 矩形の右下隅を表す横座標(スケール値:省略時は0)
%4 | 矩形の右下隅を表す縦座標(スケール値:省略時は0)
%5 | 境界線の線幅(省略時は1)
%6 | 矩形の塗り潰し濃度(0～8:省略時は0)
書式例 表示/印刷イメージ
$BOX=10,10,20,20
$BOX=10,10,20,20,2
$BOX=10,10,20,20,1,3

→戻る

楕円

楕円( [image]) デフォルト ELLIPSE=%1,%2,%3,%4,%5,%6
境界矩形として指定した矩形に収まる最大の楕円を描きます。
線幅が0の時には楕円の枠線は印刷されません。
塗り潰し濃度は0(塗り潰さない)から8(もっとも濃く)の間で指定します。
楕円は描画色で枠線を、背景色で塗り潰し部分を印刷します。
書式 | パラメータ
$ELLIPSE=%1,%2,%3,%4,%5,%6 | %1 | 楕円の境界矩形の左上隅を表す横座標(スケール値:省略時は0)
%2 | 楕円の境界矩形の左上隅を表す縦座標(スケール値:省略時は0)
%3 | 楕円の境界矩形の右下隅を表す横座標(スケール値:省略時は0)
%4 | 楕円の境界矩形の右下隅を表す縦座標(スケール値:省略時は0)
%5 | 楕円の線幅(省略時は1)
%6 | 楕円の塗り潰し濃度(0～8:省略時は0)
書式例 表示/印刷イメージ
$ELLIPSE=10,10,20,20
$ELLIPSE=10,10,20,20,2
$ELLIPSE=10,10,20,20,1,3

→戻る

角の丸い矩形

角の丸い矩形( [image]) デフォルト ROUNDBOX=%1,%2,%3,%4,%5,%6,%7,%8
指定した矩形を描きます。
四隅には丸い角が指定した大きさの楕円を使用して描かれます。
線幅が0の時には矩形の枠線は印刷されません。
塗り潰し濃度は0(塗り潰さない)から8(もっとも濃く)の間で指定します。
矩形は描画色で枠線を、背景色で塗り潰し部分を印刷します。
書式 | パラメータ
$ROUNDBOX=%1,%2,%3,%4,%5,%6,%7,%8 | %1 | 矩形の左上隅を表す横座標(スケール値:省略時は0)
%2 | 矩形の左上隅を表す縦座標(スケール値:省略時は0)
%3 | 矩形の右下隅を表す横座標(スケール値:省略時は0)
%4 | 矩形の右下隅を表す縦座標(スケール値:省略時は0)
%5 | 丸い角を描く楕円の幅(スケール値:省略時は0)
%6 | 丸い角を描く楕円の高さ(スケール値:省略時は0)
%7 | 図形の線幅(省略時は1)
%8 | 図形の塗り潰し濃度(0～8:省略時は0)
書式例 表示/印刷イメージ
$ROUNDBOX=10,10,20,20,5,5
$ROUNDBOX=10,10,20,20,5,5,2
$ROUNDBOX=10,10,20,20,5,5,1,3

→戻る

円弧

円弧( [image]) デフォルト ARC=%1,%2,%3,%4,%5,%6,%7
境界矩形として指定した矩形に収まる最大の楕円を通る円弧を開始角から終了角に向けて反時計方向に描きます。
円弧は描画色を使用して印刷します。
書式 | パラメータ
$ARC=%1,%2,%3,%4,%5,%6,%7 | %1 | 弧の境界矩形の左上隅を表す横座標(スケール値:省略時は0)
%2 | 弧の境界矩形の左上隅を表す横座標(スケール値:省略時は0)
%3 | 弧の境界矩形の左上隅を表す横座標(スケール値:省略時は0)
%4 | 弧の境界矩形の左上隅を表す横座標(スケール値:省略時は0)
%5 | 弧の開始角(反時計周り:0～359:省略時は0)
%6 | 弧の終了角(反時計周り:0～359:省略時は0)
%7 | 弧の線幅(省略時は1)
書式例 表示/印刷イメージ
$ARC=10,10,30,20,0,45
$ARC=10,10,30,20,90,135,2

→戻る

扇形

扇形( [image]) デフォルト PIE=%1,%2,%3,%4,%5,%6,%7,%8
境界矩形として指定した矩形に収まる最大の楕円を通る円弧を開始角から終了角に向けて反時計方向に描き、その両端から楕円の中心に直線を描いた扇形が描かれます。
線幅が0の時には扇形の枠線は印刷されません。
塗り潰し濃度は0(塗り潰さない)から8(もっとも濃く)の間で指定します。
扇形は描画色で枠線を、背景色で塗り潰し部分を印刷します。
書式 | パラメータ
$PIE=%1,%2,%3,%4,%5,%6,%7,%8 | %1 | 弧の境界矩形の左上隅を表す横座標(スケール値:省略時は0)
%2 | 弧の境界矩形の左上隅を表す縦座標(スケール値:省略時は0)
%3 | 弧の境界矩形の右下隅を表す横座標(スケール値:省略時は0)
%4 | 弧の境界矩形の右下隅を表す縦座標(スケール値:省略時は0)
%5 | 弧の開始角(反時計周り:0～359:省略時は0)
%6 | 弧の終了角(反時計周り:0～359:省略時は0)
%7 | 図形の線幅(省略時は1)
%8 | 図形の塗り潰し濃度(0～8:省略時は0)
書式例 表示/印刷イメージ
$PIE=10,10,30,20,0,120
$PIE=10,10,30,20,120,240,2
$PIE=10,10,30,20,240,0,2,5

→戻る

バーコード

バーコード( [image]) デフォルト BARCODE=%1,%2,%3,%4,%5,%6,%7
指定した位置にバーコードを描画します。
Interludeでは次のバーコードに対応しています。
それぞれのバーコードに関する制限事項などはこちらを参照してください。
バーコードの幅指定を0にするとInterludeが適当な大きさを設定しますので、通常は0を設定してください。

※郵便カスタマバーコードは、幅・高さともに規定の長さがあるため、幅・高さともに0と指定することをお勧めします。
※QRコードは、幅・高さともに同じ値を指定することをお勧めします。
書式 | パラメータ
$BARCODE=%1,%2,%3,%4,%5,%6,%7 %1 対象となるバーコード形式に基づいた文字列

CODE128、ENA-128共通
・'CODEA'、'STX'などの制御コードは、'|CODEA|'、'|STX|'のように'|'で囲んで指定します。
・キャラクタの'|'を指定する場合は、'|||'のように記述します。

CODE128の場合
・'STARTx'から始める必要があります。

EAN-128の場合
・'(30)'のように、'()'が含まれていてもバーコードには影響しません。 %7 の'draw'では描画されます。
%2 | バーコード種別 | 説明
JAN | JAN/EAN/UPC
NW7 | NW-7 (CODA BAR)
ITF | ITF (Interleaved 2 of 5)
CODE39 | CODE 3 of 9
JAN8 | 短縮JAN
UPCE | UPC Eバージョン
POST | 郵便カスタマバーコード
CODE128 | CODE128
EAN128 | EAN-128
QR | QRコード
%3 | 印刷するバーコードの左上隅の横座標(スケール値:省略時は0)
%4 | 印刷するバーコードの左上隅の縦座標(スケール値:省略時は0)
%5 | 印刷するバーコードの幅(スケール値:省略時は0:0を指定した場合はバーコードの規定幅)※1
%6 | 印刷するバーコードの高さ(スケール値:省略時は0:0を指定した場合はバーコードの規定高)※1
%7
対象バーコード パラメータ
(郵便カスタマバーコード)、(QRコード)以外が対象
draw | バーコード文字列の描画※2
drawex | バーコード文字列の描画(現在のフォント)※2、※3
(QRコード)のみ対象
0 | 誤り訂正レベル 7% (デフォルト)
1 | 誤り訂正レベル 15%
2 | 誤り訂正レベル 25%
3 | 誤り訂正レベル 30%
※1
  ・郵便カスタマバーコードは、幅・高さともに規定の長さがあるため、幅・高さともに0と指定することをお勧めします。
  ・QRコードは、幅・高さともに同じ値を指定することをお勧めします。
※2
  ・'draw'または、'drawex'の指定が無いと描画されません
  ・CODE128でCODEAの'NUL'から'RS'までは、CODEBのキャラクタで描画されます。それ以外の制御コードは、描画されません。
  ・バーコードの長さを超えて描画できませんので、'$TEXT='等で代用することをお勧めします。
※3
  ・バーコードを指定する前に、制御機能のフォント指定('ESCカ'など)をする必要があります。
JAN( [image]) デフォルト BARCODE-JAN=%1,%2,%3,%4,%5,%6
JAN/EAN/UPC形式のバーコードを描画します。
NW-7( [image]) デフォルト BARCODE-NW7=%1,%2,%3,%4,%5,%6
NW-7(CODA BAR)形式のバーコードを描画します。
ITF( [image]) デフォルト BARCODE-ITF=%1,%2,%3,%4,%5,%6
ITF(Interleaved 2 of 5)形式のバーコードを描画します。
CODE39( [image]) デフォルト BARCODE-CODE39=%1,%2,%3,%4,%5,%6
CODE 3 of 9形式のバーコードを描画します。
短縮JAN( [image]) デフォルト BARCODE-JAN8=%1,%2,%3,%4,%5,%6
短縮JAN形式のバーコードを描画します。
UPC-E( [image]) デフォルト BARCODE-UPCE=%1,%2,%3,%4,%5,%6
UPC形式(Eバージョン)のバーコードを描画します。
POST( [image]) デフォルト BARCODE-POST=%1,%2,%3
郵便カスタマバーコード形式のバーコードを描画します。
CODE128( [image]) デフォルト BARCODE-CODE128=%1,%2,%3,%4,%5,%6
CODE128のバーコードを描画します。
EAN-128( [image]) デフォルト BARCODE-EAN128=%1,%2,%3,%4,%5,%6
CODE128のバーコードを描画します。
QRコード( [image]) デフォルト BARCODE-QR=%1,%2,%3,%4,%5,%6
QRコードのバーコードを描画します。
書式 | パラメータ
$BARCODE-JAN=%1,%2,%3,%4,%5,%6 | それぞれのパラメータは共通です
$BARCODE-NW7=%1,%2,%3,%4,%5,%6 | %1 | 指定するバーコード形式に基づいたバーコード
$BARCODE-ITF=%1,%2,%3,%4,%5,%6 | %2 | 印刷するバーコードの左上隅の横座標(スケール値:省略時は0)
$BARCODE-CODE39=%1,%2,%3,%4,%5,%6 | %3 | 印刷するバーコードの左上隅の縦座標(スケール値:省略時は0)
$BARCODE-JAN8=%1,%2,%3,%4,%5,%6 | %4 | 印刷するバーコードの幅(スケール値:省略時は0:0を指定した場合はバーコードの規定幅)
$BARCODE-UPCE=%1,%2,%3,%4,%5,%6 | %5 | 印刷するバーコードの高さ(スケール値:省略時は0:0を指定した場合はバーコードの規定高)
$BARCODE-POST=%1,%2,%3 | %6 | '$BARCODE='の%7パラメータと同じ
$BARCODE-CODE128=%1,%2,%3,%4,%5,%6
$BARCODE-EAN128=%1,%2,%3,%4,%5,%6
$BARCODE-QR=%1,%2,%3,%4,%5,%6
書式例 | 表示/印刷イメージ | 備考
$BARCODE=490123456789,JAN,10,10,0,20 | $BARCODE-JAN,490123456789,10,10,0,20 でも同様
$BARCODE=49012345,NW7,10,10,0,20,draw | $BARCODE-NW7,49012345,10,10,0,20,draw でも同様
$BARCODE=49012345678,ITF,10,10,0,20 | $BARCODE-ITF,49012345678,10,10,0,20 でも同様
$BARCODE=4901JAN,10,10,0,20,draw | $BARCODE-CODE39,4901,10,10,0,20,draw でも同様
$BARCODE=4901234,JAN8,10,10,0,20 | $BARCODE-JAN8,4901234,10,10,0,20 でも同様
$BARCODE=4901234,UPCE,10,10,0,20,draw | $BARCODE-UPCE,4901234,10,10,0,20 でも同様
$BARCODE=46000072-48-1-5,POST,10,10 | $BARCODE-POST,46000072-48-1-5,10,10 でも同様
$BARCODE=|STARTA|123|STX||||ABC,CODE128,10,10,0,0,draw | $BARCODE-CODE128=|STARTA|123|STX||||ABC,10,10,0,0,draw でも同様
$BARCODE=(10)1097(01)983102(30)05,EAN128,10,10,0,0,drawex | (縮小フォント) | $BARCODE-EAN128=(10)1097(01)983102(30)05,10,10,0,0,drawex でも同様
$BARCODE=㈱マイクロリンク,QR,10,10,0,0,2 | (拡大イメージです) | $$BARCODE-QR=㈱マイクロリンク,10,10,0,0,2 でも同様

→戻る

画像

画像( [image]) デフォルト BMPFILE=%1,%2,%3,%4,%5
指定した位置にビットマップを描画します。表示可能色数を超えたピットマップは減色して表示します。幅・高さを共に0にすることで、ビットマップ本来の大きさで表示/印刷することが可能です。
書式 | パラメータ
$BMPFILE=%1,%2,%3,%4,%5 | %1 | ビットマップのファイル名(カレントフォルダは帳票ファイルのフォルダになります)
%2 | ビットマップの左上隅の横座標(スケール値:省略時は0)
%3 | ビットマップの左上隅の縦座標(スケール値:省略時は0)
%4 | ビットマップの幅(スケール値:省略時は0:0を指定した場合は本来のビットマップの幅)
%5 | ビットマップの高さ(スケール値:省略時は0:0を指定した場合は本来のビットマップの幅)
書式例 表示/印刷イメージ
$BMPFILE=Interlude.bmp,10,10
$BMPFILE=Interlude.bmp,10,10,50,50

→戻る

テキスト

テキスト( [image]) デフォルト TEXT=%1,%2,%3,%4,%5,%6
任意の位置に任意のフォントとサイズでテキストを描きます。
フォント名は正確に指定する必要があります。ＭＳ ゴシックなどスペース文字が必要なものがありますので注意が必要です。
書式 | パラメータ
$TEXT=%1,%2,%3,%4,%5,%6 | %1 | テキスト
%2 | 始点の横座標(スケール値:省略時は0)
%3 | 始点の縦座標(スケール値:省略時は0)
%4 | フォント名
%5 | フォントサイズ
%6 以下のオプションを任意で指定
(いくつでも可:省略時は無指定)
オプション | 効果
b | ボールド体(太字)
u | アンダーライン(下線)
i | イタリック体(斜体)
s | 打ち消し線
d | 始点座標をテキストの左下とする
r | 始点座標をテキストの右上とする
書式例 表示/印刷イメージ
$TEXT=ＭＳ 明朝(10),10,10,ＭＳ 明朝,10
$TEXT=ＭＳ ゴシック(15)b,10,10,ＭＳ ゴシック,15,b
$TEXT=ＭＳ 明朝(20)u,10,10,ＭＳ ゴシック,20,u
$TEXT=ＭＳ ゴシック(10)i,10,10,ＭＳ ゴシック,10,i
$TEXT=ＭＳ 明朝(15)s,10,10,ＭＳ 明朝,15,s
角度付テキスト( [image]) デフォルト STEXT=%1,%2,%3,%4,%5,%6,%7
任意の位置に任意のフォント・サイズ・角度でテキストを描きます。
書式 | パラメータ
$STEXT=%1,%2,%3,%4,%5,%6,%7 | %1 | テキスト
%2 | 始点の横座標(スケール値:省略時は0)
%3 | 始点の縦座標(スケール値:省略時は0)
%4 | 角度(1/10度単位:省略時は0)
%5 | フォント名
%6 | フォントサイズ
%7 以下のオプションを任意で指定
(いくつでも可:省略時は無指定)
オプション | 効果
b | ボールド体(太字)
u | アンダーライン(下線)
i | イタリック体(斜体)
s | 打ち消し線
書式例 表示/印刷イメージ
$STEXT=ＭＳ 明朝(10),10,10,450,ＭＳ 明朝,10
中央配置テキスト( [image]) デフォルト CTEXT=%1,%2,%3,%4,%5,%6,%7,%8
指定した矩形の中央に任意のテキストを描きます。
矩形が実際に描かれるテキストよりも小さい場合は、矩形でクリップされるので矩形外の領域には影響を及ぼしません。
書式 | パラメータ
$CTEXT=%1,%2,%3,%4,%5,%6,%7,%8 | %1 | テキスト
%2 | 矩形の左上隅を表す横座標(スケール値:省略時は0)
%3 | 矩形の左上隅を表す縦座標(スケール値:省略時は0)
%4 | 矩形の右下隅を表す横座標(スケール値:省略時は0)
%5 | 矩形の右下隅を表す縦座標(スケール値:省略時は0)
%6 | フォント名
%7 | フォントサイズ
%8 以下のオプションを任意で指定
(いくつでも可:省略時は無指定)
オプション | 効果
b | ボールド体(太字)
u | アンダーライン(下線)
i | イタリック体(斜体)
s | 打ち消し線
書式例 表示/印刷イメージ
$CTEXT=ＭＳ ゴシック(15),10,10,200,30,ＭＳ ゴシック,15
矩形配置テキスト( [image]) デフォルト BTEXT=%1,%2,%3,%4,%5,%6,%7,%8
テキストを指定した矩形の中に流し込み描画します。
テキストは矩形内に収まるように配置されますが、矩形内に収まらない場合はクリップされ、矩形外の領域には影響を及ぼしません。
書式 | パラメータ
$BTEXT=%1,%2,%3,%4,%5,%6,%7,%8 | %1 | テキスト
%2 | 矩形の左上隅を表す横座標(スケール値:省略時は0)
%3 | 矩形の左上隅を表す縦座標(スケール値:省略時は0)
%4 | 矩形の右下隅を表す横座標(スケール値:省略時は0)
%5 | 矩形の右下隅を表す縦座標(スケール値:省略時は0)
%6 | フォント名
%7 | フォントサイズ
%8 以下のオプションを任意で指定
(いくつでも可:省略時は無指定)
オプション | 効果
b | ボールド体(太字)
u | アンダーライン(下線)
i | イタリック体(斜体)
s | 打ち消し線
書式例 表示/印刷イメージ
$BTEXT=ＭＳ 明朝(20),10,10,50,50,ＭＳ 明朝,20
均等配置テキスト( [image]) デフォルト DTEXT=%1,%2,%3,%4,%5,%6,%7,%8
テキストを指定した矩形の中に均等割付します。
テキストの中にスペース文字が含まれていると正確な均等配置ができない場合がありますので、なるべく含めないようにした方が良いでしょう。
書式 | パラメータ
$DTEXT=%1,%2,%3,%4,%5,%6,%7,%8 | %1 | テキスト
%2 | 矩形の左上隅を表す横座標(スケール値:省略時は0)
%3 | 矩形の左上隅を表す縦座標(スケール値:省略時は0)
%4 | 矩形の右下隅を表す横座標(スケール値:省略時は0)
%5 | 矩形の右下隅を表す縦座標(スケール値:省略時は0)
%6 | フォント名
%7 | フォントサイズ
%8 以下のオプションを任意で指定
(いくつでも可:省略時は無指定)
オプション | 効果
b | ボールド体(太字)
u | アンダーライン(下線)
i | イタリック体(斜体)
s | 打ち消し線
書式例 表示/印刷イメージ
$DTEXT=ＭＳゴシック(10),10,10,400,30,ＭＳ ゴシック,10

→戻る

色指定

描画色指定( [image]) デフォルト PCOLOR=%1,%2,%3
テキストの描画色など拡張制御命令で描かれるすべての色を設定します。
初期の状態では黒(すべてのパラメータが0)です。
背景色指定( [image]) デフォルト BCOLOR=%1,%2,%3
矩形の内部など拡張制御命令で塗り潰しに使われるすべての色を設定します。
初期の状態では黒(すべてのパラメータが0)です。
書式 | パラメータ
$PCOLOR=%1,%2,%3 | それぞれのパラメータは共通です
%1 | 赤要素(0～255)
$BCOLOR=%1,%2,%3 | %2 | 緑要素(0～255)
%3 | 青要素(0～255)
書式例 表示/印刷イメージ
$PCOLOR=255,0,0
$TEXT=赤文字,10,10,ＭＳ 明朝,15
$PCOLOR=255,0,0
$BOX=10,10,200,20
$BCOLOR=0,255,0
$BOX=10,10,200,20,0,5
$BCOLOR=0,0,255
$BOX=10,10,200,20,0,5

→戻る

移動

移動( [image]) デフォルト MOVE=%1,%2
現在の描画位置を指定した位置に移動させます。
この命令は通常のテキストを制御する唯一の拡張制御命令で、以降のテキストはこの命令で指定した横座標で桁合わせ処理が行われます。
詳しい動作はサンプルデータをInterludeで開いてご確認ください。
書式 | パラメータ
$MOVE=%1,%2 | %1 | 移動先の横座標(スケール値:省略時は0)
%2 | 移動先の縦座標(スケール値:省略時は0)
書式例 処理内容
$MOVE=100i,100i 描画位置を横1インチ縦1インチの位置に移動
以降改行処理後の描画位置は常に横1インチの位置から

→戻る

ファイル挿入

ファイル挿入( [image]) デフォルト INCLUDE=%1
帳票テキストファイル内に指定したテキストを挿入します。
挿入するファイルの動作環境(座標登録・各種設定など)は元々の帳票設定のものが使用されるため、座標登録機能で制御を行う場合などには注意が必要です。
詳しい動作はサンプルデータをInterludeで開いて確認してください。
書式 | パラメータ
$INCLUDE=%1 | %1 | 挿入するテキストファイルのファイル名
書式例 処理内容
AAA
$INCLUDE=サンプル.TXT
BBB 		AAA行とBBB行の間にサンプル.TXTの内容を挿入します

→戻る

壁紙指定

壁紙指定( [image]) デフォルト WALLPAPER=%1,%2,%3
ビットマップを壁紙として画面に表示します。
壁紙として指定したビットマップは印刷されませんので、設計時には必要で印刷時には不要な画像などを表示する場合に有効です。
書式 | パラメータ
$WALLPAPER=%1,%2,%3 | %1 | 壁紙として表示するビットマップファイルのファイル名
%2 | ビットマップの幅(スケール値:省略時は0:0を指定した場合は本来のビットマップの幅)
%3 | ビットマップの高さ(スケール値:省略時は0:0を指定した場合は本来のビットマップの幅)
書式例 | 処理内容
$WALLPAPER=Interlude.bmp | 壁紙としてInterlude.bmpを表示しますが、この画像は印刷されません

→戻る

エイリアス

エイリアス( [image]) デフォルト ALIAS=%1,%2
別名(エイリアス)の定義を行います。
定義したエイリアスは %ALIAS% のように %キーワード% として使用することができます。また予めいくつかのキーワードはInterludeによって設定されています。これらの内容は エイリアスについて(Tips) を参照してください。
書式 | パラメータ
$ALIAS=%1,%2 | %1 | 定義するキーワード
%2 | エイリアスで置き換える文字列
書式例 表示/印刷イメージ 備考
$ALIAS=TEXT,ＭＳ 明朝(10)
$ALIAS=FONT,ＭＳ 明朝
$TEXT=%TEXT%,10,10,%FONT%,10 		%TEXT%と%FONT%がエイリアスによって置き換えられています

→戻る

この文書の著作権は株式会社マイクロリンクが保有しています。
Copyright (C) 1997-2005 MICROLINK Corp.


このページではFrequency Answer of Question(よくある質問とその回答)を掲載しています。
一般 設定 プリンタ MAGIC Previewer 障害 その他

◇一般◇

Q | Interludeを起動したのですが、まずは何をすれば良いのでしょうか?
A | Interludeは印刷をするためのアプリケーションですので、まずは手近にあるテキストファイルやInterludeに添付されているサンプルファイルを印刷してみてはいかがでしょう? そのためにはまずInterludeでファイルを開くことから始まります。ドラッグアンドドロップでの起動ももちろん可能です。ファイルを開くとInterludeはプリンタに印刷するイメージそのままで表示を行います。あとはメニューから印刷を選ぶことでお手持ちのプリンタに印刷されることでしょう。

Q | プリンタのインストールが必要らしいのですが、プリンタが無いとInterludeは使えないのですか?
A | Interludeは印刷をするためのアプリケーションですので、プリンタがあることが前提になります。ただし、印刷をしないで設計だけを行う場合や表示だけを行う場合はプリンタのドライバをインストールさえしてあれば実際にプリンタが接続してなくても正常に動作します。 ※もちろん印刷のためにはプリンタ本体が必要です。

Q | 帳票ウィンドウがある大きさ以上にサイズ変更することができないのですが?
A | 帳票ウィンドウは用紙サイズ以上の大きさにすることができないようになっています。

Q | プログラムからInterludeを使って印刷だけをさせたいのですが、Interludeの画面を表示させないで自動的に印刷する方法はあるのでしょうか?
A | Interludeに起動オプション -p を指定することで可能です。詳しくは Tips をご覧ください。

Q | バーコードを印刷したいのですが、バーコードの大きさは変更できますか?
A | パラメータの設定で可能です。ただし郵便カスタマバーコードは規定で全体の大きさが決まっているため、規定外の大きさで使用した場合には何らかのトラブルが発生する可能性がありますのでご注意ください。 ※郵便物が受領されない可能性があります。

Q | InterludeをViewerのように使いたいのですが、クライアントが設定情報を変更してしまうなどのヒューマンエラーが心配です。できれば設定変更が出来なくなればこんな心配をしなくて済むのですがそういった事はできるのでしょうか?
A | Interludeを実行モードで起動すれば帳票設定やシステム設定の変更を抑制することが可能です。実行モードでの起動方法は Tips をご覧ください。

Q | 図形が色々と描けるようなのですが破線や点線というのも描けますか?
A | 破線や点線などの線種に関する設定はできません。少々手間がかかりますが、ビットマップを使用することで代用することはできます。また、モノクロプリンタに印刷する場合には色設定を上手に使用することで濃淡のある線を描く事は可能です。 ※プリンタによってはその結果として点線になる場合もあるようです。

Q | Metronomeって何をするアプリケーションですか?
A | MetronomeはInterludeを制御するスケジューラです。複数の印刷処理をまとめて行ったり、指定時間になるまで印刷を待機したりすることができます。

◇設定◇

Q | 設定内容はどこに保存されるのですか?
A | すべての設定内容はレジストリに保存されます。 ※位置はHKEY_CURRENT_USER\Software\MICROLINK\Interludeです。

Q | 設定内容がレジストリに保存されるとのことですが、開発中のコンピュータと納入先のコンピュータが違う場合は納入先で改めて設定しないといけないのですか?
A | 設定内容はファイルとして出力することができます。別のコンピュータでも同じ設定を使う場合には出力した設定ファイルをインポートすることでまったく同じ設定にすることができます。

Q | Windows NT で開発を進めているのですが、あるユーザで設定した内容が別のユーザには反映されていないことがあるみたいなのですが?
A | Windows NT のレジストリはユーザ毎になっているため、そのような現象が起こります。これを解消するためには別コンピュータで同じ設定を使用する場合と同様にエクスポート・インポート機能を使用します。

Q | プリンタの開始位置をレフトマージンと垂直タブで指定できるようなのですが、これらは文字単位や行単位での設定しかできないようです。もう少し細かい単位(インチとか)で指定する方法はないものでしょうか?
A | 帳票の設定ではご指摘のように文字単位や行単位でしか印字開始位置を制御することはできませんが、拡張制御命令を使用することで任意の位置に印字開始位置を設定することができます。詳しくは Tips をご覧ください。

◇プリンタ◇

Q | プリンタの設定方法がわかりません。 プリンタの設定を変えたのですが、Interludeで反映されません。なぜですか?
A | プリンタの設定は帳票設定ダイアログで行います。コントロールパネルのプリンタ設定でどんなに変更しても、Interludeで設定した内容が優先されますのでInterlude内で設定を行うようにして下さい。

Q | 1つ1つの帳票ファイル毎にプリンタの設定をするのは面倒なのですが良い方法はないのですか?
A | 何も設定していない帳票ファイルの設定はデフォルトという名前の設定が有効になります。つまりデフォルトの設定を変更しておけば多くの設定を変更するのと同じ効果が得られます。 また、設定は個別に複製することが可能ですので、この方法で同じ設定のものを複数作成するという事も可能です。

Q | プリンタの設定はレジストリに保存され、他のコンピュータに設定ファイルを持っていくとその設定で動作するとの事ですが、インポートしたコンピュータに設定したプリンタのドライバがインストールされていない場合はどうなるのですか?
A | 設定したプリンタのプリンタドライバが見つからない場合にはWindowsで設定している通常使うプリンタを使用します。この場合には設定されている情報はすべて使用されませんが、用紙サイズなどの基本情報だけは継承されます。 ※この場合には帳票ウィンドウにその旨の表示があります。また、この処理によって設定内容が自動的に変更されることはありません。

Q | Interludeで表示されているフォントと印刷されるフォントが違う事があります。印刷イメージそのままに表示できるはずではないのですか?
A | プリンタによってはWindowsのフォントではなく、プリンタのフォントを使用する機能を持ったものがあります。Interludeはプリンタが所持しているフォントを使用する事はできませんので、その場合には印刷イメージと表示イメージが異なるといった現象が発生するわけです。 この現象を回避するためにはプリンタのプロパティでフォントの置き換えをしないように設定変更する必要があります。プリンタのプロパティをご確認ください。

Q | サポートしているプリンタを教えてください
A | 各メーカ様がWindows95およびWindowsNT4.0対応として出荷されているプリンタであれば、Interludeで使用する事が可能です。 プリンタ固有の問題で印刷に不具合が発生する場合は、プリンタのプロパティを再度確認して頂くかドライバを最新のものに変更する事で不具合が回避されることがあります。

◇MAGIC Previewer◇

Q | MAGIC PreviewerはWindows NTでの動作をサポートしていませんでしたが、Interludeはサポートしているのでしょうか? またサポートしているバージョンは?
A | InterludeではWindowsNTのバージョン4.0をサポートしています。ただしプリンタドライバの関係上、WindowsNTとWindows95のクロス開発では若干の制限事項があります。詳しくは 制限事項 をご覧ください。 ※WindowsNTのバージョン3.51以前のバージョンでは動作しません。

Q | MAGIC Previewerではカラープリンタでバーコードを印字すると正常に印刷されない現象があったようなのですが、Interludeでは大丈夫ですか?
A | Interludeではカラープリンタをサポートしていますので大丈夫です。ただしバーコードの色は変更できませんのでご了承ください。

Q | MAGIC Previewerでは設定してあるプリンタドライバが存在しないとトラブルが起こっていたようですが、Interludeではどうですか?
A | Interludeでは設定されているプリンタドライバが見つからない時は通常使うプリンタを代替として使用するようになりました。

Q | MAGIC Previewerを使用しているのですが、Interludeに変更することで何かメリットはあるのですか?
A | MAGIC Previewerは元々Windows3.1をベースに開発されたものでWindows95で新しく導入されているロングファイル名などの機能には未対応でした。またWindowsNTでの動作もサポートしていませんでした。Interludeではこれらの問題点を解消し、さらに各種の新しい機能が組み込まれていますし高速化も図られていますので、Windows3.1を使用されていないのであればぜひInterludeに変更することを強くお勧めいたします。 ※InterludeはWindows3.1では動作しません。

Q | MAGIC PreviewerからInterludeへ移行しようとしているのですが、データなどの継承はどのようにするのでしょうか?
A | MAGIC Previewerの設定ファイルをそのままInterludeのインポート機能で取り込む事ができますので、設定情報のほとんどは引き継ぐ事が可能です。

Q | MAGIC PreviewerからInterludeへ移行する際の注意点について教えてください。
A | 基本的にMAGIC Previewerで正常に印刷されていた帳票はそのままInterludeでも印刷することが可能です。ただし、バーコードに関しては処理プログラムの刷新によって大きさの初期値や印刷形式の変更があるため、デザイン上の問題が発生することがあります。 ただし、基本的な処理方法がMAGIC PreviewerとInterludeでは異なるため、MAGIC Previewerでは発生していなかった表示上または印刷上の誤差がInterludeで表面化するなど必ずしもMAGIC Previewerを使用して印刷していたイメージでInterludeが印刷できるわけではありません。

Q | InterludeはMAGIC Previewerの後継アプリケーションとの事ですが、今後MAGIC Previewerの開発・販売は行われないのですか?
A | InterludeはWindows3.1で動作しないため、Windows3.1を使用されている方々のためにMAGIC Previewerの販売は継続させて頂いております。今後MAGIC Previewerのバージョンアップなどは予定されておりませんが、致命的なバグの修正や特に要望の多いものに関しては修正などが行われる事もあります。

◇障害◇

Q | 実行すると comctl32.dllのエラー が発生して起動できないのですが、原因は何でしょう?
A | comctl32.dllのバージョンが古いとエラーが発生することがあります。Windows95またはNTのサービスパックやInternet ExplorerのインストールなどでDLLのアップデートを行う事でエラーは発生しなくなります。 この不具合はInterludeのバージョン2.001.066およびMetronomeのバージョン2.001.006では修正されています。

Q | 座標の抽出を行っても指定した位置とはズレたところが抽出されるようです。原因は何でしょう?
A | ディスプレイの設定でフォントサイズが変更されていると座標を認識できないことがあります。この値を100%(または小さなフォント)にすることで回避することができます。 この不具合はInterludeのバージョン2.002.068では修正されています。

Q | 実行モードで回転系の表示が乱れますが、原因は何でしょう?
A | NT4.0上での実行モードで回転機能・角度付きテキストの表示が乱れます。 この不具合はInterludeのバージョン2.002.068では修正されています。

Q | 罫線補完機能を使用するように設定しても補完がされないことがあるのですが、原因は何でしょう?
A | 罫線の含まれる行に制御機能が使用されていると補完作業が行われないことがあります。 この不具合はInterludeのバージョン2.002.068では修正されています。

◇その他◇

Q | なぜヘルプがHTML形式で書かれているのですか?
A | TipsやFAQなどを弊社ホームページで更新する予定ですが、その情報をローカルの環境でもファイルをお手元にコピーしていただくだけで利用できるようにするためです。

Q | Interludeってどんな意味?
A | Interludeとは英語で間奏曲という意味です。設計から印刷の間で、またコンピュータからプリンタの間で活躍するアプリケーションであることから、それぞれの処理を旋律とみなし間奏曲という意味のInterludeが名付けられました。

Q | 書籍タイプのマニュアルはありませんか?
A | 書籍タイプのマニュアルは用意されておりません。将来的にはInterlude用のファイルとしてマニュアルを提供することがあるかもしれませんので、その際にはお手元のプリンタで印刷して頂くことになります。

この文書の著作権は株式会社マイクロリンクが保有しています。
Copyright (C) 1997,1998 MICROLINK Corp.


Interlude とは英語で間奏曲の意。あなたの作業と作業の間を奏でます...。

Copyright (C) 1996-2005 MICROLINK Corp.


スタートページ

機能概要

メニュー

帳票設定

システム設定

制御機能

拡張制御機能

スケジュール機能
(Metronome)

バーコード

制限事項

Tips

FAQ


このページではInterludeの制限事項や、MAGIC Previewerとの差異についての情報を掲載しています。

プリンタ

  • 最低でも1つのプリンタがインストールされていないとInterludeは正常動作しません。これはInterludeが画面に表示するための情報を取得する際に、必ずプリンタドライバの情報が必要となるためです。
  • 一部のプリンタで、図形などが正常に印刷されないなどの現象が発生する場合があります。
    その場合はドライバを最新のものに変更すると改善される場合があります。
  • Windows95とWindowsNTでクロス開発を行う場合にはプリンタドライバが異なる関係上、同じプリンタであってもドライバが正しく認識できず、インポートした場合でもすべての情報を引き継ぐ事ができない場合があります。
    この現象は特にネットワークプリンタを使用する場合に多く発生します。これはWindowsNTでのプリンタドライバ名は接続しているネットワークポート名になる場合があり、このドライバ名を同一プリンタかどうかの判断としているInterludeが認識ミスを起こすためです。

バーコード

  • Interludeは弊社MAGIC Previewerの後継アプリケーションとして制作されましたが、バーコードの印刷イメージの一部がMAGIC Previewerと異なります。

ファイル

  • Interludeはロングファイルネームに対応していない環境では正常な動作を行えない可能性があります。
  • 一覧から選択できるファイル数は最大100ファイルです。

制御命令

  • MAGIC Previewerでは一部の制御命令(ボールドなど)は改ページ後も有効でしたが、Interludeではページごとに再設定する必要があります。


このページではメニューに関するリファレンスを掲載しています。
ファイルメニュー
表示メニュー
設定メニュー
ウィンドウメニュー
ヘルプメニュー

ファイルメニュー

開く ( [image])
保存されている帳票テキストファイルを新たに開きます。一度開いたファイルは履歴に残り、後述する一覧選択やメニューからのダイレクト選択が利用できます。
一覧から開く ( [image])
これまでに開いた帳票テキストファイルの中から開くファイルを選択します。一覧表示されている名称は帳票設定で設定した帳票名が表示されます。
再読み込み ( [image])
現在開いている帳票テキストファイルを読み直します。閉じる→開くを繰り返すことなく最新の情報を見ることができます。
閉じる
現在開いているファイルを閉じます。
印刷 ( [image])
開いているファイルをプリンタに印刷します。
実行モード( [image])
実行モードに移行します。実行モードでは一切のファイル操作および設定操作をすることができません。
エディタ起動
開いているファイルに関連付けられたアプリケーションを起動します。
基本的にどのようなアプリケーションも起動する事が出来ます。
通常はテキストエディタに関連付けをして、Interludeからエディタを起動できるようにすることを推奨します。
Metronome起動
Interlude用のスケジューラであるMetronomeを起動します。Metronomeのヘルプはこちら。
アプリケーションの終了
Interludeを終了します。
→戻る

表示メニュー

ツールバー
スタンダードバー( [image])
ページバー( [image])
ツールバー( [image])
スケールバー( [image])
それぞれのツールバーの表示を切り替えます。
ステータスバー
ステータスバーの表示を切り替えます。
実行モードのツールバー
ダイアログバー( [image])
ツールバー( [image])
表示しない
実行モードでどのタイプのツールバーを表示するかを選びます。この設定はすべての帳票で有効になります。
ページ移動
前のページ( [image])
1つ前のページを表示します。
次のページ( [image])
1つ先のページを表示します。
ページを戻す( [image])
5ページ前のページを表示します。
ページを進める( [image])
5ページ先のページを表示します。
先頭ページ( [image])
先頭のページを表示します。
最終ページ( [image])
最後のページを表示します。
ページ選択( [image])
任意のページを選択します。
ズーム
拡大( [image])
表示イメージを拡大します。
縮小( [image])
表示イメージを縮小します。
拡大率の設定( [image])
表示イメージを指定した拡大率で表示します。
ルーラ
水平ルーラ
表示( [image])
ルーラの表示を切り替えます。
文字単位( [image])
ルーラの目盛りを文字単位に変更します。
目盛りの数値は1/1文字単位です。拡張制御命令で指定する座標は1/10文字単位なので、数値の取り扱いには注意が必要です。
インチ単位( [image])
ルーラの目盛りをインチ単位に変更します。
目盛りの数値は1/10インチ単位です。拡張制御命令で指定する座標は1/100インチ単位なので、数値の取り扱いには注意が必要です。
ミリ単位( [image])
ルーラの目盛りをミリメートル単位に変更します。
目盛りの数値は1/1ミリメートル単位です。拡張制御命令で指定する座標は1/10ミリメートル単位なので、数値の取り扱いには注意が必要です。
垂直ルーラ
表示( [image])
ルーラの表示を切り替えます。
文字単位( [image])
ルーラの目盛りを文字単位に変更します。
目盛りの数値は1/1文字単位です。拡張制御命令で指定する座標は1/10文字単位なので、数値の取り扱いには注意が必要です。
インチ単位( [image])
ルーラの目盛りをインチ単位に変更します。
目盛りの数値は1/10インチ単位です。拡張制御命令で指定する座標は1/100インチ単位なので、数値の取り扱いには注意が必要です。
ミリ単位( [image])
ルーラの目盛りをミリメートル単位に変更します。
目盛りの数値は1/1ミリメートル単位です。拡張制御命令で指定する座標は1/10ミリメートル単位なので、数値の取り扱いには注意が必要です。
グリッド
表示( [image])
グリッドの表示を切り替えます。
グリッドを下にする( [image])
グリッドを帳票イメージの下に表示するようにします。
グリッドを上にする( [image])
グリッドを帳票イメージの上に表示するようにします。
→戻る

設定メニュー

帳票設定( [image])
それぞれの帳票テキストファイル別に各種設定を行います。設定できる内容はこちらをご覧ください。
システム設定( [image])
Interludeで使用する各種制御命令をカスタマイズします。
座標抽出( [image])
座標を画面上でポイントすることでその情報を記録します。 → 座標抽出機能について

→戻る

ウィンドウメニュー

横方向に最大化( [image])
ウィンドウを横方向のみに最大化します。ただし用紙サイズ以上には最大化することはできません。
縦方向に最大化( [image])
ウィンドウを縦方向のみに最大化します。ただし用紙サイズ以上には最大化することができません。
全方向に最大化( [image])
ウィンドウを最大化します。ただし用紙サイズ以上には最大化することができません。
重ねて表示
開いている帳票ウィンドウを重ねて表示します。
並べて表示
開いている帳票ウィンドウを並べて表示します。
アイコンの整列
最小化している帳票ウィンドウの整列をします。

→戻る

ヘルプメニュー

バージョン情報( [image])
Interludeのバージョン情報を表示します。
ヘルプ( [image])
このヘルプを呼び出します。

→戻る


このページではInterludeのスケジューラであるMetronomeについて掲載しています。

機能概要

MetronomeはInterlude専用のスケジューラアプリケーションです。複数の帳票をまとめて印刷したり、指定時刻に印刷を開始させるなどといった制御を行う事ができます。

画面説明

動作種別
即時 | スケジュール開始と同時に処理を開始します。
時間指定 | スケジュール開始と同時に指定した時間まで待機して、指定時間になると処理を開始します。

制御
制御に関する設定は次の2つです。
バッチ処理 チェックすると各スケジュール項目を順番に処理していきます。1台のプリンタに対してスケジュール処理を行う場合に有効です。チェックを外すとすべてのスケジュール項目を同時に実行します。これは複数のプリンタに印刷する場合に効果的です。
ログ出力 チェックするとMetronomeの処理内容をログファイルに出力します。
※ログファイル名はMetronome.logで固定です。

スケジュール項目
処理の内容が表示されます。処理は先頭行から順に行われます。項目の左側にあるチェックボックスを外すとその処理は行われなくなります。また、編集時のページ入力で0を指定すると先頭ページや最終ページを指定することと同等になります。

コマンドラインからの起動

コマンドラインのオプションなどの書式は以下の通りです。
[USAGE] Metronome {[filename]} {-p}
filename | 起動時に開くファイル名を指定します
-p | 起動と同時にスケジュールを開始します


このヘルプについて

このヘルプはHTML形式で記述しています。左のフレームでカテゴリを選択すると、このフレームで詳細な内容がご覧頂けます。
また、このヘルプはMicrosoft Interner Explorer 3.02で正しく表示されることを確認しています。

概要

Interludeは帳票印刷のアシスタントツールです。また、帳票印刷に限らずソースコードの印刷など多彩な印刷をアシスタントします。さまざまなTipsはこのヘルプの中でも紹介しています。

ご案内

Interludeの最新情報や、ヘルプには間に合わなかった最新機能、新たなTipsなどは弊社WebPageで公開中です。

おことわり

このヘルプで記載されているシステム・製品名などは一般に各社の登録商標または商標です。


このページではInterludeの持つ豊富な機能について掲載しています。

文字の装飾

通常のテキスト表示への装飾はボールド体・イタリック体・アンダーラインに加え、色の変更や網掛け・文字の回転・文字サイズ変更と様々な機能があります。これらに加えて、拡張制御命令を使用すれば、任意の位置に任意のフォント・角度に自由にテキストを配置することができ、様々な表現で帳票を演出することが可能です。

参考 → 制御機能,拡張制御機能

テキストの流し込み

拡張制御命令を使用すれば、決まった領域に文章を流し込むことができます。行幅を考慮することなく、複数行を枠内に収めることが可能です。

参考 → 矩形配置テキスト(拡張制御機能)

テキストの均等配置

拡張制御命令を使用すれば、決まった領域内にテキストを収めることができます。表のヘッダ部分などで使用すれば見映えも随分と良くなります。

参考 → 均等配置テキスト(拡張制御機能)

印刷位置の指定方法

印刷位置の指定などには文字単位・インチ単位・ミリメートル単位の3種類の方法が可能です。桁合わせなど文字単位の情報を使用したい場合、グラフィックなど実測数値の情報を使用したい場合、それぞれ用途に合わせた指定が可能です。

参考 → 座標の指定方法(Tips)

ファイル挿入

予め書式を別のファイルで作成しファイル挿入機能を使用すれば、決まったレイアウトをいつも使用することができます。またヘッダ部分を作成しておいて、明細部分のファイルの先頭に
挿入すればプログラム作成の手間も減らすことができます。
ファイル挿入にはページの先頭や終わりにファイルを付加するものと任意の位置にファイルを挿入するものといった2つの方法があり、用途に合わせて利用することができます。

参考 → ファイル挿入(拡張制御命令)

座標登録機能

座標登録機能を使用すると細かい座標設定をひとつひとつ数値で入力する必要がなくなります。予めテキストに座標登録用のデータをセットしておき、後は画面上で位置をポイントすることで簡単に設計を行うことが可能です。

参考 → 座標登録機能の使い方(Tips),フォームオーバーレイのテクニック(Tips)

エイリアス機能

ページ数などの文書情報を任意の位置に入れることができます。また、エイリアスのキーワードは自由に作成できるため、定型文書にデータを流し込むといった場合にもエイリアス機能は重要な機能となるでしょう。

参考 → 定義済みエイリアス一覧(Tips),ページ番号を印刷するには(Tips)

CSV形式に対応

CSV形式のファイルを使用すると、各項目が自動的に決められたエイリアスへと設定されます。予め設計を行ったファイルを併用すれば、各種データベースアプリケーションから印刷への工数は激減します。

参考 → CSV形式のデータを扱うテクニック(Tips)

すべての制御命令がカスタマイズ可能

豊富な機能を実現する様々な制御命令はすべてカスタマイズが可能です。一つ一つの命令を覚えるよりも自分の好みの命令でInterludeを制御することが可能になります。

参考 → システム設定

スケジューラで夜間運転も可能

Interlude付属のスケジューラであるMetronomeを使用することで複数の帳票を連続で印刷させたり、指定の時間に印刷を開始させたりすることができます。プリンタの使用頻度が高い時間帯にはデータだけを出力させ、使用頻度の低い時間帯にまとめて印刷させることも簡単にできます。

参考 → スケジュール機能


このページではシステム設定ダイアログでの設定方法を掲載しています。
システム設定では、制御機能や拡張制御機能の書式のカスタマイズを行います。すべての書式は設定されていますが、ほとんどの書式がDOS版dbMAGICから使用の場合の簡便性やMAGIC Previewerとの互換性を重視して作成されているため、現行のシステムでは適していない設定もいくつか存在します。
このような書式設定のほとんどを再設定可能にすることで、使用される方の嗜好に合わせたシステム構築を設計することも可能になっています。
設定方法
ツリーから設定する内容を選択すると、設定内容と説明が表示されますので自由に設定してください。ただし、他の制御命令と書式が重なる場合は正常に機能しない場合がありますので注意が必要です。
制御機能のパラメータ書式
パラメータを指定する場合は次のような書式で表します。
基本は %+パラメータ番号+パラメータ種別 となります。
書式 | 内容 | 書式例 | 使用例 | 効果
%1d | 1番目のパラメータに1桁の10進数値を設定する | e%1d | e5 | 1番目のパラメータに5が設定されます
%2D | 2番目のパラメータに2桁の10進数値を設定する | T%2D | T20 | 2番目のパラメータに20が設定されます
%1x | 1番目のパラメータに1桁の16進数値を設定する | R%1x | Ra | 1番目のパラメータに10(0x0a)が設定されます
%2X | 2番目のパラメータに2桁の16進数値を設定する | C%2X | C60 | 2番目のパラメータに96(0x60)が設定されます

指定されている桁数は必ず必要になります。また使用しないパラメータはすべて初期値(ほとんどの場合は0)が適用されます。
拡張制御命令のパラメータ書式
拡張制御命令でのパラメータを指定する場合は次のように表します。
基本は %+パラメータ番号 となります。
書式 | 内容 | 書式例 | 使用例 | 効果
%1 | 1番目のパラメータにデータを設定します | TEST=%1 | TEST=FOO | 1番目のパラメータにFOOが設定されます
%1,%2 1番目と2番目のパラメータにデータを設定します
1番目と2番目のデータの区切りには , を使用します 		TEST=%1,%2 TEST=FOO1,FOO2 1番目のパラメータにFOO1が
2番目のパラメータにFOO2が設定されます

パラメータの指定による数値や文字などの区別はありません。また使用しないパラメータはすべて初期値が適用されます。
デフォルト
すべての項目を初期値に戻します。Interludeがバージョンアップして機能が追加された場合は必ず初期値に戻す作業が必要になります。また、以前にデモ版を使用されていた方も初めに初期値に戻す作業を行ってください。
インポート
エクスポートした設定ファイルを読み込みます。すべての設定はインポートした内容に置き換わります。
エクスポート
設定内容を設定ファイルに書き出します。ファイル名はInterludeSystem.iniで固定です。


このページではInterludeを使用する上でのテクニックや、他のページでは触れられなかった特殊な設定方法など、さまざまな情報を掲載しています。
# | 種別 | 内容
0001 | 機能 | 座標の指定方法
0002 | 機能 | 座標登録機能の使い方
0003 | 表 | 定義済みのエイリアス一覧
0004 | 表 | コマンドラインのオプション一覧
0005 | 表 | 印刷時に起動するアプリケーションで使用できるエイリアス文字一覧
0006 | テクニック | カンマの入ったテキストを印刷するテクニック
0007 | テクニック | フォームオーバーレイのテクニック
0008 | テクニック | プログラムソースを印刷するには
0009 | テクニック | ページ番号を印刷するには
0010 | テクニック | CSV形式のデータを扱うテクニック
0011 | コラム | なぜ制御命令がカスタマイズできるのか
0012 | 機能 | レジストリテーブル


#0001:座標の指定方法 [機能]

Interludeの拡張制御命令を使用して直線や矩形などを描く場合、その位置を決める方法としてスケール値という特殊な書式を使用します。スケール値は「数値＋単位指定子」で表し、単位指定子によってインチ単位であるかミリメートル単位であるかを示すようになっています。
座標位置を指定する場合は、どの指定子を使用した場合も帳票のもっとも左上を0とした数値を表します。

単位指定子 | 機能 | 備考
.(ピリオド) | 1/10文字単位を表す | 単位指定子が無い場合も同様。 1文字の幅は帳票設定の文字種類・文字間隔に依存するため、絶対位置が必要な場合には不向き。 1文字の高さは約1/6インチです。
i | 1/100インチ単位を表す |
m | 1/10ミリメートル単位を表す |

指定例 | 意味
100 | 10文字目を表す
100. | 10文字目を表す
100i | 1インチを表す
100m | 10ミリメートルを表す

使用方法 | 効果
$LINE=10,10,100i,100i | 横10文字目・縦10文字目の位置から横1インチ・縦1インチの位置に直線を描く

Tipsの先頭に戻る


#0002:座標登録機能の使い方 [機能]

Interludeの座標登録機能を使用すると、画面上で設計作業を行う事ができます。手順例を以下に示します。

手順 | 作業 | 備考
1 | まずは以下のようなテキストをあらかじめ作成しておきます。 $TEXT=テキスト,%0X%,%0Y%,ＭＳ ゴシック,10 | %0X%や%0Y%の説明は後述します。
2 | 作成したテキストをInterludeで開きます。 | この時点では一番左上にテキストと表示されているはずです。
3 | メニューから座標抽出を選びます。 | F11キーでも同様です。
4 | カーソルが変わりますので、帳票ウィンドウの好きな位置でクリックします。 | 画面に収まりきらない部分を選択したい場合はカーソルキーで画面を動かすことが可能です。
5 | 座標登録ダイアログが表示されますので、リストボックスの0番が選択されていることを確認し、OKを押してください。 | 0が選択されていない時は選択をした後にOKを押します。
6 | すると画面が更新され、先ほど選択した位置にテキストが表示されます。 |

この一連の作業で使用した%0X%と%0Y%は、共に登録した座標を使用することを表すエイリアス処理の一つです。

書式 | 機能 | 備考
%nX% | n番に登録した座標の横座標にエイリアスする | nは0～999までです。 登録してない番号を指定した場合は0になります。
%nY% | n番に登録した座標の縦座標にエイリアスする | nは0～999までです。 登録してない番号を指定した場合は0になります。

指定例 | 意味
%10X% | 10番に登録した座標の横座標にエイリアスする
%50Y% | 50番に登録した座標の縦座標にエイリアスする

使用方法 | 効果
$LINE=%0X%,%0Y%,%1X%,%1Y% | 0番に登録した位置から1番に登録した位置に直線を描く

Tipsの先頭に戻る


#0003:定義済みのエイリアス一覧 [表]

Interludeで予め定義されているエイリアスは以下の通りです。

エイリアス名 | 内容
PAGE | ページ番号
TOTAL | 総ページ数
FORM | 文書名 ※文書名が登録されていない場合はファイル名
FONT | 使用フォント名
LINES | 設定行数
WORDS | 設定桁数
TABS | 設定タブ数
PITCH | 設定改行幅
HMARGIN | 設定レフトマージン
VMARGIN | 設定垂直タブ
%nX% | 座標登録機能で登録したデータ(横座標) ※nは0～999の数値
%nY% | 座標登録機能で登録したデータ(縦座標) ※nは0～999の数値
%CSVnnn% | CSV形式で読み込んだデータ ※nは0～999の数値

使用例 | 効果
%10X% | 座標登録機能で10番に設定した座標の横座標
%20Y% | 座標登録機能で20番に設定した座標の縦座標
%CSV012% | CSV形式で読み出された13番目のデータ ※最初のデータは0番のため

Tipsの先頭に戻る


#0004:コマンドラインのオプション一覧 [表]

Interludeをコマンドラインで起動する場合のオプションです。
オプションの順序に制限はありません。ファイル名の前についても後ろについてもどちらでも解釈されます。
オプション名 | 機能
-v | 実行モードで起動します。 実行モードでは設定変更ができないなど機能に制限を持たせる事ができます。
-p | 起動と同時に印刷を行います。 Interlude自身は画面上に現れず、印刷終了後は自動的にInterludeも終了します。
-pn,m | 起動と同時にnページからmページまでの印刷を行います。 nを省略した場合は先頭ページからの印刷を、mを省略した場合は最終ページまでの印刷を行います。
-o | 起動と同時にファイル選択ダイアログを表示します。
-f | Interludeを常に最前面に表示するようにします。
-t0 | 実行モードのツールバーを表示しないようにします。
-t1 | 実行モードではダイアログバーを表示するようにします。
-t2 | 実行モードではツールバーを表示するようにします。
-!RegKey | 設定を記録するレジストリテーブルを指定します。
-@filename | 起動と同時に設定ファイルをインポートします。 レジストリテーブルが指定されていない場合は、インポートするファイル名でテーブルを作成します。

コマンドライン例 | 内容
Interlude -p テスト.txt | テスト.txtを印刷します。
Interlude -v テスト,txt | テスト.txtを実行モードで起動します。
Interlude -v -t0 テスト.txt | テスト.txtをツールバー無しの実行モードで起動します。 ※単純なブラウザとしてInterludeが使用できます。
Interlude -!サンプル | レジストリテーブルとして サンプル を使用してInterludeを起動します。
Interlude -p テスト.txt -@テスト1.ini | テスト.txtを印刷しますが、印刷前にテスト1.iniをインポートします。 この場合にレジストリテーブルとして テスト1.ini を使用します。 ※同じ帳票ファイルで複数の設定を使用したい場合に有効です。
Interlude -p テスト.txt -!サンプル -@テスト1.ini | テスト.txtを印刷しますが、印刷前にテスト1.iniをインポートします。 この場合にレジストリテーブルとして サンプル を使用します。 ※同じ帳票ファイルで複数の設定を使用したい場合に有効です。
Interlude -p テスト.txt -!Config -@テスト1.ini | テスト.txtを印刷しますが、印刷前にテスト1.iniをインポートします。 この場合にレジストリテーブルとして Config を使用します。 ※Configはデフォルトのレジストリテーブルです。 ※デフォルトのレジストリテーブルにインポートする場合にはこのように指定します。

Tipsの先頭に戻る


#0005:印刷時に起動するアプリケーションで使用できるエイリアス文字一覧 [表]

印刷時に起動するアプリケーション(印刷前・印刷後も同様)で指定できるエイリアス文字は以下の通りです。
制御文字 | 置き換えるパラメータ
%l | 行数
%c | 桁数
%t | タブ
%f | 改行幅
%e | 拡張ESC
%x | 拡張FS
%m | レフトマージン
%v | 垂直タブ
%d | デフォルト文字
%n | 印刷ファイル名

Tipsの先頭に戻る


#0006:カンマの入ったテキストを印刷するテクニック [テクニック]

初期設定のまま使用している場合、拡張制御命令のTEXTなどの書式はパラメータがすべてカンマで区切られています。そのため、そのままではTEXT命令を使ってカンマの入ったテキストを印刷することは不可能です。
カンマの入ったテキストを印刷するための方法には次の2種類があります。

  1. システム設定で書式を変更する。
    一番簡単な方法です。例えば次のように変更します。
    初期設定 | 変更後
    TEXT=%1,%2,%3,%4,%5,%6 | TEXT="%1",%2,%3,%4,%5,%6

    このように変更する事で、%1に入るデータは "" で囲まれた文字となるためカンマが入っていてもパラメータの区切りとは見なされずにデータとして認識されるのです。
    書式例
    $TEXT="\1,000-",10,10,ＭＳ ゴシック,20,b

  2. エスケープ文字を使用する。
    システム設定を変更するのは簡単なのですが、すべての帳票ファイルに有効となるため他の作業に与える影響も少なくありません。そういう場合は特別なエスケープ文字を使用する事をお勧めします。
    このエスケープ文字は拡張制御命令のパラメータのみで使用できるもので、パラメータ中に\,(\に続いてカンマを入れる)とすると、その部分はカンマに置き換えられるというものです。
    書式例 | 備考
    $TEXT=\1\,000-,10,10,ＭＳ ゴシック,20,b | 1.と同様の結果を得られます。

Tipsの先頭に戻る


#0007:フォームオーバーレイのテクニック [テクニック]

フォームオーバーレイには2種類の方法があります。それは、

  1. すでに専用の帳票があり、そのイメージの上にデータを重ねる方法。
  2. 専用の帳票を作成し、データとともに印刷をする方法。

1.の場合は、専用伝票などがすでに存在する場合ですが、その際には以下のような手順で作業を進めると効率的に作業を行うことが出来ます。

手順 | 作業 | 備考
1 | 専用伝票をスキャナで取り込みビットマップファイルを作成します。 | または伝票のおおまかなデザインをビットマップとして作成します。
2 | 取り込んだ専用伝票の大きさを定規などで実際に計ります。 | スキャナで取り込む場合は余白部分などを取り込むことがあるため、その分も考慮する必要があります。
3 | 帳票テキストファイルのページの先頭行に拡張制御命令の壁紙機能を使用して1.で作成したビットマップを指定します。 | サイズの指定は2.で計測した値を使用します。
4 | 拡張制御命令のテキスト命令などを使用してデータ部分を配置していきます。この時の位置指定には座標登録機能を使用するため、%0X%などを指定しておきます。 | 詳しくは座標登録機能の説明をご覧ください。
5 | Interludeでテキストを開き、プリンタの設定を行う。 この時に用紙をユーザー定義を指定し、用紙サイズを2.で計測した値にする。 | これで1ページの大きさを帳票の大きさとすることができます。
6 | 座標登録機能を使用してそれぞれのデータを配置する場所を設定していきます。 | 実際に帳票イメージを見ながら配置作業を行うことができます。

テキスト例 | 備考
$WALLPAPER=専用帳票.bmp,350i,100i $TEXT=住所,%0X%,%0Y%,ＭＳ ゴシック,20 $TEXT=名前,%1X%,%1Y%,ＭＳ ゴシック,20 | 横3.5インチ・縦1インチの帳票に2つのテキストを印刷する場合のサンプルです。

2.の場合は、専用帳票をビットマップなどで作成するか、拡張制御命令の直線・矩形描画機能などを使用して帳票のイメージを印刷する方法を使います。

手順 | 作業 | 備考
1 | 専用伝票をビットマップファイルで作成します。 | または伝票のおおまかなデザインを直線や矩形などを使用して作成します。
2 | 帳票テキストファイルのページの先頭行に拡張制御命令のピットマップ描画機能を使用して1.で作成したビットマップを指定、または直線や矩形命令を先頭部分に指定します。 | サイズの指定は実際に印刷する大きさを使用します。
3 | 拡張制御命令のテキスト命令などを使用してデータ部分を配置していきます。この時の位置指定には座標登録機能を使用するため、%0X%などを指定しておきます。 | 詳しくは座標登録機能の説明をご覧ください。
4 | Interludeでテキストを開き、プリンタの設定を行う。 この時に用紙をユーザー定義を指定し、用紙サイズを2.で指定した値にする。 | これで1ページの大きさを帳票の大きさとすることができます。
5 | 座標登録機能を使用してそれぞれのデータを配置する場所を設定していきます。 | 実際に帳票イメージを見ながら配置作業を行うことができます。

テキスト例 | 備考
$BMPFILE=専用帳票.bmp,350i,100i $TEXT=住所,%0X%,%0Y%,ＭＳ ゴシック,20 $TEXT=名前,%1X%,%1Y%,ＭＳ ゴシック,20 | 横3.5インチ・縦1インチの帳票に2つのテキストを印刷する場合のサンプルです。

プログラムでテキストを作成する場合などは、予めダミーのテキストファイルを作成し、その上で設定作業を行うと効率良く作業を行うことができます。

Tipsの先頭に戻る


#0008:プログラムソースを印刷するには [テクニック]

プログラムソースを印刷する場合にデフォルトの設定を使用すると、行間や文字間が広いために一枚の紙に入る情報量がどうしても少なくなってしまいます。ここでは効率よくプログラムソースを印刷するための設定方法をいくつか挙げたいと思います。

  1. 行数指定の変更
    この設定は0に変更しておきます。0にすることで用紙をムダなく使用することができます。
  2. 改行幅の変更
    日本語が多く含まれる文章であればデフォルトの改行幅(1/6インチ)は非常に読みやすいのですが、アルファベットが多く含まれるプログラムソースなどではどうしても間延びした感じがしてしまいます。Cプログラムなどでは16くらいの数値を設定すると良いでしょう。
  3. 文字種類・文字間隔の変更
    デフォルトはパイカに設定されていますが、文字間隔が広いために比較的桁数を必要とするプログラムソースの印刷には向いていません。プログラムソースを印刷する場合には半角の間隔2くらいを設定すると良いでしょう。
  4. 桁数指定の変更
    文字種類・文字間隔を変更すると、ある程度を桁数を確保することができます。ですが、設定桁数を適度な値に設定しないと一定位置で自動的に改行処理が行われてしまいますので、画面を見ながら適当な値を設定してください。

この手順は、通常の文章を印刷する場合にも大きく参考となることでしょう。

Tipsの先頭に戻る


#0009:ページ番号を印刷するには [テクニック]

プログラムソースを印刷する場合、長い文書を印刷する場合など何ページにも渡る印刷を行う場合にはそれぞれのページにページ番号を印刷しておくことで後々の管理が行いやすくなります。Interludeでページ番号を印刷するためには次のような方法を使います。

手順 | 内容
1 | エイリアス機能である%PAGE%や%TOTAL%を使用してページ印刷部分だけのテキストを作成する。
2 | ファイルを保存して、帳票設定のページ番号を必要とするファイルのヘッダに指定する。

書式例 | 効果
$TEXT=%PAGE%/%TOTAL%,700i,10i,ＭＳ ゴシック,14,b $MOVE=0i,20i | MOVE命令を入れるのは、テキストが印刷するページ番号に重ならないようにするためです。

Tipsの先頭に戻る


#0010:CSV形式のデータを扱うテクニック [テクニック]

InterludeでCSV形式のデータを扱うには、ファイルの拡張子が.CSVまたは.ICVである必要があります。.CSVの場合は1行を1ページ分のデータとして処理するのに対して、.ICVの場合は行数指定で指定した行数分を1ページのデータとして処理します。
また、CSV形式で読み取ったデータは%CSV000%のようにエイリアスとして使用しますが、この場合に実際にデータを印刷するフォームにあたる部分は、別にファイルを作成しフッタとして設定することで機能します。つまり座標登録機能を使用する場合もCSVファイルの設定で行う必要があります。詳しくは使用例がサンプルにありますので参照してください。

CSVファイルの中身 | エイリアスの内容 |  | 備考
"ABC",DEF,"123",456 | CSV000 | ABC | ダブルクォーテーション("")で囲まれたデータも、囲まれていないデータも正しく認識します。
 | CSV001 | DEF
 | CSV002 | 123
 | CSV003 | 456

ICVファイルの中身 | エイリアスの内容 |  | 備考
"ABC",DEF,"123",456 "GHI",JKL,"789",012 | CSV000 | ABC | 行数指定が2に設定されている場合。
 | CSV001 | DEF
 | CSV002 | 123
 | CSV003 | 456
 | CSV004 | GHI
 | CSV005 | JKL
 | CSV006 | 789
 | CSV007 | 012

例
Interlude.csvのデータをInterlude_header.txtのフォーム上に配置して印刷する場合は、Interlude.csvの帳票設定のヘッダ欄にInterlude_header.txtと設定し、Interlude.csvを印刷するようにします。

Tipsの先頭に戻る


#0011:なぜ制御命令がカスタマイズできるのか [コラム]
制御命令のほとんどがカスタマイズできるということは、多くのアプリケーションでは行われておらず、また実際に製品のクオリティにはほとんど影響しません。では、なぜInterludeはそういった機能が付いているのでしょう。
ある言語(マクロ言語を含む)を初めて使う時には、まずその文法に慣れる必要があります。ところが...例えばC言語の知識を持ってPascalを使う場合...など、どうしても文法的に馴染めない言語というのが必ず存在します。
かつて、BASICで直線を描くには LINE(x1,y1)-(x2,y2),n であったものが 現在の多くのC言語系では、 line(hDC,x1,y1,x2,y2) のようになっていたり、同じ処理を行うにしても言語によって記述方法が異なるということは現在では当然のように行われています。
ですが、このような苦労は本来無駄な作業です。同じ処理を行うのになぜ別の言葉を覚えなければいけないのでしょう? ましてやInterludeの制御命令は単純なマクロ文法です。マクロのような単純なものにそのような苦労をかけてしまうのでは却ってツールを使う意味が無くなりかねません。
そこでInterludeではカスタマイズを可能にしたのです。たとえば楕円を描く命令 ELLIPSE を CIRCLE に変更することも、矩形を描く命令 BOX を RECTANGLE に変更することもユーザの自由ですべて行うことができます。また、パラメータの順序も自由に変更できます。ユーザの好みにあった構文にすることが可能ということは、ユーザの好みの開発環境を作り出すことに繋がるのです。

Tipsの先頭に戻る


#0012:レジストリテーブル [機能]

Interlude のバージョン2.007.079から追加されたレジストリテーブルを使用することで、同じファイルに対して複数の設定を行うことができるようになりました。保存するレジストリキーをコマンドラインで設定することが可能になっています。設定方法は以下の通りです。
コマンドライン例 | 効果
Interlude -!サンプル | レジストリテーブルとしてサンプルを指定します。

また、コマンドラインからのインポート指定を行うと、そのインポートファイル名をレジストリテーブルとして起動します。
コマンドライン例 | 効果
Interlude -@サンプル.ini | 起動時にサンプル.iniをインポートします。 また、レジストリテーブルとしてサンプル.iniを指定します。

この2つのオプションは同時に使用することができます。
コマンドライン例 | 効果
Interlude -!サンプル -@サンプル.ini | 起動時にサンプル.iniをインポートします。 レジストリテーブルとしてサンプルを指定します。

通常のレジストリテーブルに対して単純にコマンドラインからインポートする場合は、レジストリテーブルをConfigと指定します。
コマンドライン例 | 効果
Interlude -!Config -@サンプル.ini | 起動時にサンプル.iniをインポートします。 レジストリテーブルは通常のものを指定します。

Tipsの先頭に戻る